#! /usr/bin/env php AWS SDK for PHP PHP Environment Compatibility Test (CLI) ---------------------------------------- PHP 5.2 or newer... 5.5.9-1ubuntu4.17 cURL with SSL... 7.35.0 (OpenSSL/1.0.1f) Standard PHP Library... Yes SimpleXML... Yes JSON... Yes PCRE... Yes File system read/write... Yes OpenSSL extension... Yes Zlib... Yes APC... Yes XCache... No Memcache... No Memcached... No PDO... Yes SQLite 2... No SQLite 3... No PDO-SQLite driver... No ---------------------------------------- Your environment meets the minimum requirements for using the AWS SDK for PHP! * The OpenSSL extension is installed. This will allow you to use CloudFront Private URLs and decrypt Windows instance passwords. * The Zlib extension is installed. The SDK will automatically leverage the compression capabilities of Zlib. * Storage types available for response caching: The file system, APC ---------------------------------------- Bottom Line: Yes, you can! Your PHP environment is ready to go, and can take advantage of all possible features!